Composer install drupal/search_api_solr / drupal/search_api failed

Submitted by Gast (nicht überprüft) on Mi, 07/24/2019 - 13:43

Woran liegt das, dass weder drupal/search_api_solr noch drupal/search_api aktualisiert werden kann?

 

#  composer require 'drupal/search_api:^1.14'

./composer.json has been updated
Gathering patches for root package.
No patches supplied.
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: don't install drupal/search_api 1.14.0
    - drupal/search_api 1.x-dev conflicts with drupal/search_api_solr[2.7.0].
    - drupal/search_api_solr 2.7.0 conflicts with drupal/search_api[1.x-dev].
    - drupal/search_api 1.x-dev conflicts with drupal/search_api_solr[2.7.0].
    - Installation request for drupal/search_api ^1.14 -> satisfiable by drupal/search_api[1.x-dev, 1.14.0].
    - Installation request for drupal/search_api_solr (locked at 2.7.0, required as ^2.3) -> satisfiable by drupal/search_api_solr[2.7.0].

Installation failed, reverting ./composer.json to its original content.

 

 

# composer require 'drupal/search_api_solr:^3.2'

./composer.json has been updated
Gathering patches for root package.
No patches supplied.
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for drupal/search_api_solr ^3.2 -> satisfiable by drupal/search_api_solr[3.x-dev, 3.2.0].
    - Can only install one of: drupal/search_api[1.x-dev, 1.13.0].
    - Can only install one of: drupal/search_api[1.13.0, 1.x-dev].
    - Can only install one of: drupal/search_api[1.x-dev, 1.13.0].
    - Conclusion: install drupal/search_api 1.x-dev
    - Installation request for drupal/search_api (locked at 1.13.0, required as ^1.11.0) -> satisfiable by drupal/search_api[1.13.0].

Installation failed, reverting ./composer.json to its original content.

 

Neuen Kommentar schreiben

This question is for testing whether or not you are a human visitor and to prevent automated spam submissions.