Drupal

The 'core_version_requirement' constraint (^9.4 || ^10) requires the 'core' key not be set in ...info.yml

Submitted by Gast (nicht überprüft) on Do, 10/20/2022 - 20:31

Problem (während # drush cr)

In InfoParserDynamic.php line 88:
                                                                                                                                                           
  The 'core_version_requirement' constraint (^9.4 || ^10) requires the 'core' key not be set in themes/contrib/bootstrap_barrio/bootstrap_barrio.info.yml  

Lösung :

Die Zeile mit "core: 8.x" aus der Datei "bootstrap_barrio.info.yml" entfernen. Danach sollte der Anfang so aussehen:

 

Notice: Trying to access array offset on value of type null in Drupal\views\Plugin\views\display\EntityReference->query() (Zeile 195 in ... EntityReference.php)

Submitted by Gast (nicht überprüft) on Fr, 07/08/2022 - 11:31

Das Problem (Logs überfüllt mit):

Notice: Trying to access array offset on value of type null in Drupal\views\Plugin\views\display\EntityReference->query() (Zeile 195 in /var/www/web/core/modules/views/src/Plugin/views/display/EntityReference.php)

 

 

core\modules\views\src\Plugin\views\display\EntityReference.php (Line 156):



    // $options = $this->getOption('entity_reference_options');
      $options = $this->getOption('entity_reference_options') ?? [];

 

Drupal SMTP + Gmail funktioniert nicht mehr (Passwort ist richtig); was ist die Lösung?

Submitted by Gast (nicht überprüft) on Mo, 06/20/2022 - 12:52

Seit Jahren verschickt unsere Website Emails via Drupal + SMTP + Gmail. Die Authentifizierung hat immer über MeineEmail@gmail.com und Passwort wunderbar funktioniert. 

Seit zwei Wochen gibt es aber nur noch diese Fehlermeldung : 

Fehler beim E-Mail-Versand 
SMTP Error: Could not authenticate.

Unser Passwort funktioniert und über Firefox, Chrome usw können wir uns auf Gmail ganz normal anmelden.

Was ist das Problem und wie ist die Lösung ? 

 

 

Drupal 9.3.14, gibt es diese Version wirklich ? Composer : JA, Drupal.org: NEIN !

Submitted by Gast (nicht überprüft) on Mi, 05/25/2022 - 22:16

Laut Composer gibt es 8 Updates, darunter Drupal Core 9.3.14 :

 

 0 installs, 8 updates, 0 removals
  - Upgrading doctrine/cache (1.12.1 => 1.13.0)
  - Upgrading drupal/core (9.3.13 => 9.3.14)
  - Upgrading drupal/core-composer-scaffold (9.3.13 => 9.3.14)
  - Upgrading drupal/core-project-message (9.3.13 => 9.3.14)
  - Upgrading drupal/core-recommended (9.3.13 => 9.3.14)
  - Upgrading drupal/embed (1.4.0 => 1.5.0)
  - Upgrading guzzlehttp/guzzle (6.5.5 => 6.5.6)
  - Upgrading maennchen/zipstream-php (2.1.0 => 2.2.1)